Регистрация

не вызывается процедурно утилита Mutt

Обсуждение вопросов по разработке программ в среде продуктов копорации "Progress Software"
Новичок
Аватара пользователя
Сообщения: 14
Зарегистрирован: Пн май 06, 2013 2:32 pm
Откуда: г.Москва

не вызывается процедурно утилита Mutt

Сообщение sog » Вт май 24, 2016 2:38 pm

Добрый день !

При вызове из процедуры утилиты MUTT ничего не происходит , ошибки также не видно.
os-command(value("/usr/bin/mutt -a """ + fName_full + """ -s + """ + tema + """ """ + pParam + """ < """ + telo + """")). /* не дает результата */


message ("/usr/bin/mutt -a """ + fName_full + """ -s """ + tema + """ """ + pParam + """ < """ + telo + """").

результат message вставляю в командную строку и получаю результат !!! Сообщение отправляется !

Может кто-то сталкивался с такой проблемой , может это и не проблема, но в чем дело, мне непонятно.

С уважением, Ольга

Новичок
Аватара пользователя
Сообщения: 14
Зарегистрирован: Пн май 06, 2013 2:32 pm
Откуда: г.Москва

Re: не вызывается процедурно утилита Mutt

Сообщение sog » Вт май 24, 2016 5:20 pm

Проблема решилась . можно не отвечать , с уважением, Ольга

Старожил
Аватара пользователя
Сообщения: 1523
Зарегистрирован: Чт сен 27, 2001 4:00 am
Откуда: Москва

Re: не вызывается процедурно утилита Mutt

Сообщение dmi » Ср май 25, 2016 1:35 am

sog писал(а):Проблема решилась . можно не отвечать , с уважением, Ольга


Хорошо бы еще написать как )
/dmi

http://pro4gl.ru - 4gl блог

Новичок
Аватара пользователя
Сообщения: 14
Зарегистрирован: Пн май 06, 2013 2:32 pm
Откуда: г.Москва

Re: не вызывается процедурно утилита Mutt

Сообщение sog » Ср авг 03, 2016 11:31 am

Дмитрий, поработала с кавычками ...


Вот таким образом утилита вызывается успешно

os-command silent value("mutt -a """ + name-includ + """ -s """ + iSubject + """ """ +~ iTo + """ < no-delete.txt" ).


С уважением, Ольга

Вернуться в PROGRESS - 4GL - ПРОГРАММИРОВАНИЕ

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 4