не вызывается процедурно утилита Mutt

Обсуждение вопросов по разработке программ в среде продуктов копорации "Progress Software"
Аватара пользователя
sog
Новичок
Сообщения: 14
Зарегистрирован: 06 май 2013, 13:32
Откуда: г.Москва
Контактная информация:

не вызывается процедурно утилита Mutt

Сообщение sog » 24 май 2016, 13:38

Добрый день !

При вызове из процедуры утилиты MUTT ничего не происходит , ошибки также не видно.
os-command(value("/usr/bin/mutt -a """ + fName_full + """ -s + """ + tema + """ """ + pParam + """ < """ + telo + """")). /* не дает результата */


message ("/usr/bin/mutt -a """ + fName_full + """ -s """ + tema + """ """ + pParam + """ < """ + telo + """").

результат message вставляю в командную строку и получаю результат !!! Сообщение отправляется !

Может кто-то сталкивался с такой проблемой , может это и не проблема, но в чем дело, мне непонятно.

С уважением, Ольга

Аватара пользователя
sog
Новичок
Сообщения: 14
Зарегистрирован: 06 май 2013, 13:32
Откуда: г.Москва
Контактная информация:

Re: не вызывается процедурно утилита Mutt

Сообщение sog » 24 май 2016, 16:20

Проблема решилась . можно не отвечать , с уважением, Ольга

Аватара пользователя
dmi
Старожил
Сообщения: 1523
Зарегистрирован: 27 сен 2001, 03:00
Откуда: Москва
Контактная информация:

Re: не вызывается процедурно утилита Mutt

Сообщение dmi » 25 май 2016, 00:35

sog писал(а):Проблема решилась . можно не отвечать , с уважением, Ольга


Хорошо бы еще написать как )
/dmi

http://pro4gl.ru - 4gl блог

Аватара пользователя
sog
Новичок
Сообщения: 14
Зарегистрирован: 06 май 2013, 13:32
Откуда: г.Москва
Контактная информация:

Re: не вызывается процедурно утилита Mutt

Сообщение sog » 03 авг 2016, 10:31

Дмитрий, поработала с кавычками ...


Вот таким образом утилита вызывается успешно

os-command silent value("mutt -a """ + name-includ + """ -s """ + iSubject + """ """ +~ iTo + """ < no-delete.txt" ).


С уважением, Ольга